Shinra@Posted: Mon May 04, 2009 11:27 am :
I won't bother posting my machine specs here, since I feel it has little to do with the issue at hand.

So anyway, hi, I have this teeny problem at hand:

During the second level of the recycling plant, or whatever it was named, at the very beginning you go into a small room where Betruger has a chat with you once you activate the pump.

So, my problem is as follows: when the video with Betruger plays, I can see the video, but there is no sound coming from it. Betruger talks and talks, or at least appears to, but I don't hear a thing from him. All other voices work perfectly well at all times.

Being not the least of my problems, after he is done talking, the door I came in refuses to open. Like, completely. I'm totally stuck in the small room, with no apparent means to get out. And this of course, sucks, since I can't advance in the game.

It should also be noted that I am playing the exact same copy on the exact same machine I have used to play it through previously, with no such problems. Only thing differing here is that I now have a different hard disk.

I tried uninstalling and reinstalling the game from my own copy and loading from the beginning of the level, and I even tried installing from a different copy of the game, but it still refuses to work.

So. Any ideas?

Neurological@Posted: Mon May 04, 2009 12:05 pm :
After the betruger video try opening the console, there you will see the error. Then report it here so we can look at it. But it sound like a missing sound. Does the imp break the glass after the video?

Also in what language are you playing?

Shinra@Posted: Mon May 04, 2009 1:15 pm :
Right then, took me a while to find out how to bring out the console n_n

Anyway, at the start of the level, the console gives out 3 warnings:

"WARNING: Couldn't load image: guisurfs/hazard1:1
WARNING: Couldn't load model: 'models/mapobjects/recycle/recycwallight_broken.ase'
WARNING: Couldn't load sound: 'guisounds.wav' using default

3 warnings"

That would be what the console states out.

As to your other queries:

The imp doesn't break anything. It crawls across the window during the video (and goddamn did it get me >.<), but after disappearing, it is not heard from again. I am completely stuck in the room. T_T

Also, I am playing it on English.