LEGION@Posted: Thu Oct 14, 2010 4:10 pm :
Hi there,

I extracted the original maps (in maps\game\) to add ambient light with the DarkMod-editor DarkRadiant.

It worked, but now some AI´s are walking in circles, the sentry is stupid now too, so it seems I have to dmap the maps. I did. But as I wanted to start (marscity1, the first level) I got this error:

ERROR: marscity_cinematic_sarge_1 cannot use use_aas aas48

I don´t know anything about doom3-editing, this is the first I do with doom3-maps, so I don´t know what to do now. Please, help me!

LEGION@Posted: Fri Oct 15, 2010 6:17 pm :
Other maps work fine after dmapping, it´s just that Cinematic_Sarge_1 and Sarge_2, they are on the exact same place. Oh, it´s the HQ-cinematic, where the player sees Sgt. Campell the first time, right before you have to follow the sentry.

These models seem to cause the error/can´t use AAS. I tried to move them a little out of Monsterclip, or snapping to grid, nothing helps. What´s wrong here?

rich_is_bored@Posted: Sat Oct 16, 2010 5:17 am :
It might be easier to change the timestamp of the map file rather than figure out why it's not compiling. All you've done is add a light so recompiling shouldn't be necessary.

LEGION@Posted: Sat Oct 16, 2010 2:20 pm :
Hi Rich! Changing TimeStamp didn´t helped (I used the tool: FileDate Changer v1.1), because AI were still walking in circles. But I found the solution:

In MarsCity1 were three cinematic_sarge(one player)-models that were set to use AAS48. I set them to use AAS96 instead and dmapping went fine and now it´s working. (already tested the cinematic event, went fine too)

If you´re interested: they were in the hallway to HQ, where you first encounter your chief campbell and after that you have to follow that sentry.
One 'cinematic_player_sarge' was in the hallway to that room, with a turret on the ceiling. I think that one is for a later cinematic that I don´t remember now.
The other two are in the HQ-room in front of Campell right at the door. They are both at the same origin, so you only see one. They were called like 'marscity_cinematic_sarge_1' and 'marscity_cinematic_sarge2_1' if I remember right.

First I tried with cloning them and deleting the originals. That worked for only one or two models, but not all three at the same time, that way I found out there were more models causing the error. Also I changed their position slightly and rotating them...

I also opened and saved the (already changed) map without doing anything in GtkRadiant and even Doom3ed and everytime I got that error after running 'runAAS' that was necessary because AI would walk every time in circles.
But to open the extracted map not at all, but dmapping caused no error. That leads to the conclusion that during saving the map in the editor something happened to that models. :?:

Can you tell me what the difference is between aas48 and aas96?
I saw other aas-extensions for some monster-types, so my guess is it has to do with model-proportions...