Chr1s@Posted: Mon Dec 03, 2012 6:32 pm :
I'm trying to get a simple animation to work however when I test it out the mesh appears to move within a small confined area, when I turned on bounding boxes, the box shown appears to follow the animation I set yet the mesh doesn't. See image in the link.

I have only 2 bones, "origin" and "joint1", joint1 is the bone that does the animation with the whole mesh weighted to it, it is just a simple move up and across motion, I had a more elaborate one before but ran into problems whilst trying to resolve this issue.

I'm using 3DS Max 2013 and der_ton's exporter

Eventually I'll replace the model with my own version to make it look like an earlier version of the ones found in Q4, for now just learning to animate.

Sir Random@Posted: Mon Dec 03, 2012 8:43 pm :
In 3dsmax, does the origin remain 'fixed' while joint1 moves around?

Chr1s@Posted: Mon Dec 03, 2012 9:47 pm :
Yeah it remains where I placed it, at first I used a bone for the origin but it affected my animation after I linked the other bone to it, now I'm using a helper point instead for the origin which solved the animation problem but the in game problem remained.

EDIT: Tried a shorter up and down animation and worked but when increase the distance of the up and down it hits this same invisible barrier, I've tested other animated models using testmodel/anim and they are able to move further than what I can, really puzzling me.